@halcyon ok now it's a big borked and I can't view your install documentation anymore because halcyon.social is having a cloudflare issue so idk what to do from here.

@shadow8t4 Sorry,I forgot to renew my domain at NoIP.com and it's done now but seems like it takes some time for the changes to be effective.So here's what you have to so: Add the following line to the [App] section of your config.ini:
debug_mode = true
If you didn't have this line before,that could mean that you use the same config from before your domain change.If that's true,make sure to have the correct api_client_website set and empty your /data directory.

@halcyon I set that line and changed the domain. I'm out right now but here's a screenshot from my phone. Lmk if you have any ideas.
I can log into @Shadow8t4Pics on halcyon.pro but not on my halcyon instance. I can't log into my masto.werefox.dev account or my cybre.space account on either instance but I have a feeling that can be fixed with a Mastodon update.

Follow

@shadow8t4 The debug mode didn't help unfortunately.It still doesn't work and there is no error message telling me why.After some further research I have an idea what could cause the problem but I'm not sure.Please check if your webserver has write permissions to your /data directory.I must grant the auth request again at every try so maybe the server tokens can't be stored.

@halcyon I just set data/ to 777 and it works lol...
not the best solution but yeah

Sign in to participate in the conversation
W3C CSS Working Group Mastodon

Mastodon server for anyone interested in CSS or general web development